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Android Enterprise デバイスにおいて、アプリのインストールやアンインストールができない場合に以下をご確認いただき、該当する場合は対処法をお試しください。

事象

Android Enterprise デバイスに対し、以下の操作が実行されない。

  • アプリのインストール/アンインストールができない
  • アプリ管理設定プロファイルのインストール/アンインストールができない
  • アプリケーション情報取得ができない

発生条件

  • アプリ制限プロファイルで Google Play ストアアプリ(com.android.vending)の利用を制限している
  • デバイスの電源を数週間から数ヶ月オフにしている、または電源は入っているがダイレクトブート状態である

※アプリ制限プロファイルで Google Play ストアアプリを制限していない場合でも、長期間デバイスの電源を入れずにロック画面を解除していない場合に、本事象が発生する場合がございます。定期的なロック解除を行う運用をおすすめいたします。

原因

長期間 デバイスが利用されていない場合に、Managed Google Play にアクセスするアカウントのトークン有効期限が切れたために発生する、Google Android Enterprise の仕様によるものとなります。

対処方法

事象が発生したデバイスの Play ストアアプリを手動でアップデートすることで対応が可能です。
アプリ制限プロファイルで Play ストアアプリの起動制限を行っている場合は、プロファイルを削除し、制限を解除した上で下記操作をおこなってください。

手順

1. Play Store を起動し、メニューを選択します。

2. 「設定」を選択します。

3. 「概要」を選択します。

4. 「Play ストアのバージョン」を選択します。

5. 「OK」を選択します。

Play ストア 制限について

Play ストアの制限について、Google 社から「Play プロテクト機能でデバイスをマルウェアから守るためにも Play ストアを制限することは推奨しない」との見解が出ています。
Play ストアを制限しない運用をご検討ください。

なお、Play プロテクトにつきましては、以下をご参照ください。
https://www.android.com/intl/ja_jp/play-protect/

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